CVE-2016-5734 phpMyAdmin Code Injection vulnerability
Remote attackers can execute arbitrary PHP code in phpMyAdmin via crafted strings due to improper handling of preg_replace eval modifiers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-5734?
CVE-2016-5734 is a critical code injection vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute arbitrary PHP code via a crafted string, as demonstrated by the table search-and-replace implementation.
Weakness: CWE-94
Which versions are affected by CVE-2016-5734?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.10.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.0.10.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.4.15.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.4.15.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-5734?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2016-5734 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-5734 exists.
Public exploit code: 1 Metasploit module, 1 Exploit-DB entry and 3 proofs of concept on GitHub.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2016-5734, GHSA-rv57-479x-x4qv, UBUNTU-CVE-2016-5734.