# CVE-2016-5734: phpMyAdmin Code Injection vulnerability

> Remote attackers can execute arbitrary PHP code in phpMyAdmin via crafted strings due to improper handling of preg_replace eval modifiers.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-5734, GHSA-rv57-479x-x4qv, UBUNTU-CVE-2016-5734

## What is CVE-2016-5734?

CVE-2016-5734 is a critical code injection vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute arbitrary PHP code via a crafted string, as demonstrated by the table search-and-replace implementation.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2016-5734?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.10.0 | 4.0.10.16 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.10.0 | 4.0.10.16 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.15.0 | 4.4.15.7 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.15.0 | 4.4.15.7 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.3 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-5734?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.

## Is CVE-2016-5734 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-5734 exists.

Public exploit code:

- PhpMyAdmin 4.0.x—4.6.2 Remote Code Execution Vulnerability (CVE-2016-5734) (github_poc): https://github.com/miko550/CVE-2016-5734-docker
- phpMyAdmin Authenticated Remote Code Execution (metasploit)
- https://github.com/KosukeShimofuji/CVE-2016-5734 (github_poc): https://github.com/KosukeShimofuji/CVE-2016-5734
- phpMyAdmin 4.6.2 - (Authenticated) Remote Code Execution (exploitdb)
- https://github.com/HKirito/phpmyadmin4.4_cve-2016-5734 (github_poc): https://github.com/HKirito/phpmyadmin4.4_cve-2016-5734

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5734 and fix it if it is affected.

What it is: CVE-2016-5734 is a critical code injection vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-5734 exists.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.10.0; fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.10.0; fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.15.0; fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.15.0; fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5734/ (Markdown: https://insights.sbomify.com/CVE-2016-5734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5734
- OSV: https://osv.dev/vulnerability/CVE-2016-5734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5734/
Summaries are generated and may contain mistakes; the official description above is the record.
