CVE-2016-5739 phpMyAdmin vulnerable to Cross-Site Request Forgery
Missing CSP no-referrer policy in phpMyAdmin allows attackers to read authentication tokens from Referer headers, facilitating CSRF attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-5739?
CVE-2016-5739 is a high-severity vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Transformation implementation in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not use the no-referrer Content Security Policy (CSP) protection mechanism, which makes it easier for remote attackers to conduct CSRF attacks by reading an authentication token in a Referer header, related to libraries/Header.php.
Weakness: CWE-200
Which versions are affected by CVE-2016-5739?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.10.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.0.10.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.4.15.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.4.15.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
Products include Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-5739?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.
Is CVE-2016-5739 being exploited?
There is no known exploitation of CVE-2016-5739 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Leap
Sources
Also known as DEBIAN-CVE-2016-5739, GHSA-2p7v-jm8m-g3qq, UBUNTU-CVE-2016-5739.