# CVE-2016-5739: phpMyAdmin vulnerable to Cross-Site Request Forgery

> Missing CSP no-referrer policy in phpMyAdmin allows attackers to read authentication tokens from Referer headers, facilitating CSRF attacks.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-5739, GHSA-2p7v-jm8m-g3qq, UBUNTU-CVE-2016-5739

## What is CVE-2016-5739?

CVE-2016-5739 is a high-severity vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Transformation implementation in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not use the no-referrer Content Security Policy (CSP) protection mechanism, which makes it easier for remote attackers to conduct CSRF attacks by reading an authentication token in a Referer header, related to libraries/Header.php.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-5739?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.10.0 | 4.0.10.16 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.10.0 | 4.0.10.16 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.15.0 | 4.4.15.7 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.15.0 | 4.4.15.7 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.3 |

Products: Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-5739?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.

## Is CVE-2016-5739 being exploited?

There is no known exploitation of CVE-2016-5739 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Leap

- [CVE-2015-4902](https://insights.sbomify.com/CVE-2015-4902/): Oracle Java SE Integrity Check (medium 5.3, exploited in the wild)
- [CVE-2017-14804](https://insights.sbomify.com/CVE-2017-14804/): package builds could use directory traversal to write outside of target area (critical 9.9)
- [CVE-2019-20787](https://insights.sbomify.com/CVE-2019-20787/): Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size. (critical 9.8)
- [CVE-2019-8341](https://insights.sbomify.com/CVE-2019-8341/): Code injection in n/a (critical 9.8)
- [CVE-2019-6438](https://insights.sbomify.com/CVE-2019-6438/): Other in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5739 and fix it if it is affected.

What it is: CVE-2016-5739 is a high-severity vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5739 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.10.0; fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.10.0; fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.15.0; fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.15.0; fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5739/ (Markdown: https://insights.sbomify.com/CVE-2016-5739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5739
- OSV: https://osv.dev/vulnerability/CVE-2016-5739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5739/
Summaries are generated and may contain mistakes; the official description above is the record.
