# CVE-2016-6186: Django Cross-site scripting Vulnerability

> Remote attackers can inject arbitrary web script or HTML into Django admin interfaces via unsafe innerHTML usage in the dismissChangeRelatedObjectPopup function.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Aug 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-6186, DLA-555-1, DSA-3622-1, GHSA-c8c8-9472-w52h, MGASA-2016-0282, PYSEC-2016-2, RHSA-2016:1594, RHSA-2016:1595, RHSA-2016:1596, UBUNTU-CVE-2016-6186, USN-3039-1

## What is CVE-2016-6186?

CVE-2016-6186 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 5 Aug 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjectLookups.js in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-6186?

7 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.8.14, 1.9.8, 1.10rc1 |
| `django` | PyPI | All versions | 1.8.14 |
| `django` | PyPI | From 1.10a1 | 1.10rc1 |
| `django` | PyPI | From 1.9 | 1.9.8 |
| `Django` | PyPI | All versions | 1.8.14 |
| `Django` | PyPI | From 1.10a1 | 1.10rc1 |
| `Django` | PyPI | From 1.9 | 1.9.8 |
| `python-django` | Red Hat:openstack-optools:8::el7 | All versions | 0:1.8.14-1.el7ost |
| `python-django-bash-completion` | Red Hat:openstack-optools:8::el7 | All versions | 0:1.8.14-1.el7ost |
| `python-django` | Red Hat:openstack:7::el7 | All versions | 0:1.8.14-1.el7ost |
| `python-django-bash-completion` | Red Hat:openstack:7::el7 | All versions | 0:1.8.14-1.el7ost |
| `python-django-doc` | Red Hat:openstack:7::el7 | All versions | 0:1.8.14-1.el7ost |
| `python-django` | Red Hat:openstack:8::el7 | All versions | 0:1.8.14-1.el7ost |
| `python-django-bash-completion` | Red Hat:openstack:8::el7 | All versions | 0:1.8.14-1.el7ost |

Products: Debian Debian Linux, Djangoproject Django.

## How do I fix CVE-2016-6186?

Upgrade django to a fixed version for your release line: 1.8.14, 1.9.8 or 1.10rc1.

## Is CVE-2016-6186 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-6186 exists.

Public exploit code:

- Django CMS 3.3.0 - Editor Snippet Persistent Cross-Site Scripting (exploitdb)

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6186 and fix it if it is affected.

What it is: CVE-2016-6186 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 5 Aug 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-6186 exists.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.8.14, 1.9.8, 1.10rc1
- django (PyPI): affected all versions; fixed in 1.8.14
- django (PyPI): affected from 1.10a1; fixed in 1.10rc1
- django (PyPI): affected from 1.9; fixed in 1.9.8
- Django (PyPI): affected all versions; fixed in 1.8.14
- Django (PyPI): affected from 1.10a1; fixed in 1.10rc1
- Django (PyPI): affected from 1.9; fixed in 1.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6186/ (Markdown: https://insights.sbomify.com/CVE-2016-6186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6186
- OSV: https://osv.dev/vulnerability/CVE-2016-6186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6186/
Summaries are generated and may contain mistakes; the official description above is the record.
