{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-6232 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-6232 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 2 Aug 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-6232 and fix it if it is affected.\n\nWhat it is: CVE-2016-6232 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 2 Aug 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-6232 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6232/ (Markdown: https://insights.sbomify.com/CVE-2016-6232/index.md)","id":"CVE-2016-6232","markdown":"https://insights.sbomify.com/CVE-2016-6232/index.md","name":"CVE-2016-6232","record":{"aliases":["DEBIAN-CVE-2016-6232","DLA-570-1","DSA-3643-1","GHSA-5r9j-pp34-8hph","UBUNTU-CVE-2016-6232","USN-3042-1","openSUSE-SU-2016:1884-1","openSUSE-SU-2016:2223-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"KDE Frameworks library","requires_auth":"none","summary":"Remote attackers can write to arbitrary files via directory traversal in KArchive, affecting KDE Frameworks users.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"karchives","vendor":"kde"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in KArchive before 5.24, as used in KDE Frameworks, allows remote attackers to write to arbitrary files via a ../ (dot dot slash) in a filename in an archive file, related to KNewsstuff downloads.","ecosystems":["SUSE:Package Hub 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2016-6232","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"path_traversal","year":"2016"},"n_packages":2,"n_references":10,"next":{"headline":"Zend Framework Allows SQL Injection","id":"CVE-2016-6233"},"packages":[{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["5.20.0-6.1"],"introduced":["0"],"last_affected":[],"package":"karchive","purl":"pkg:rpm/suse/karchive\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2016:1884-1"},{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["5.20.0-6.1"],"introduced":["0"],"last_affected":[],"package":"karchive","purl":"pkg:rpm/suse/karchive\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2016:2223-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-6231"},"products":["n/a"],"published":"2016-08-02","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can write to arbitrary files via directory traversal in KArchive, affecting KDE Frameworks users.","url":"https://insights.sbomify.com/CVE-2016-6232/"}