# CVE-2016-6233: Zend Framework Allows SQL Injection

> Remote attackers can execute SQL injection attacks via the order and group methods in Zend_Db_Select, potentially compromising database integrity and confidentiality.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p9hp-3gpv-52w3, MGASA-2016-0272, UBUNTU-CVE-2016-6233

## What is CVE-2016-6233?

CVE-2016-6233 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 16 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.19 might allow remote attackers to conduct SQL injection attacks via vectors related to use of the character pattern [\w]* in a regular expression.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2016-6233?

4 open source packages ship an affected version, including zendframework/zendframework and zendframework/zendframework1. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zendframework` | Packagist | All versions | 1.12.19 |
| `zendframework/zendframework` | Packagist | All versions | 1.12.19 |
| `zendframework/zendframework1` | Packagist | All versions | 1.12.19 |
| `zendframework/zendframework1` | Packagist | All versions | 1.12.19 |

Products: Fedoraproject Fedora, Zend Zend Framework.

## How do I fix CVE-2016-6233?

Upgrade zendframework/zendframework to 1.12.19 or later.

## Is CVE-2016-6233 being exploited?

There is no known exploitation of CVE-2016-6233 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6233 and fix it if it is affected.

What it is: CVE-2016-6233 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 16 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6233 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zendframework (Packagist): affected all versions; fixed in 1.12.19
- zendframework/zendframework (Packagist): affected all versions; fixed in 1.12.19
- zendframework/zendframework1 (Packagist): affected all versions; fixed in 1.12.19
- zendframework/zendframework1 (Packagist): affected all versions; fixed in 1.12.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6233/ (Markdown: https://insights.sbomify.com/CVE-2016-6233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6233
- OSV: https://osv.dev/vulnerability/CVE-2016-6233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6233/
Summaries are generated and may contain mistakes; the official description above is the record.
