# CVE-2016-6298: jwcrypto lacks the Random Filling protection mechanism


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Sep 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-6298, GHSA-wg33-x934-3ghh, PYSEC-2016-4, UBUNTU-CVE-2016-6298

## What is CVE-2016-6298?

CVE-2016-6298 is a medium-severity vulnerability in n/a, published on 1 Sep 2016. 

### Official description

The _Rsa15 class in the RSA 1.5 algorithm implementation in jwa.py in jwcrypto before 0.3.2 lacks the Random Filling protection mechanism, which makes it easier for remote attackers to obtain cleartext data via a Million Message Attack (MMA).

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-6298?

3 open source packages ship an affected version, including jwcrypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jwcrypto` | PyPI | All versions | 0.3.2 |
| `jwcrypto` | PyPI | All versions | 0.3.2 |
| `jwcrypto` | PyPI | All versions | 0.4.0 |

Products: Latchset Jwcrypto.

## How do I fix CVE-2016-6298?

Upgrade jwcrypto to a fixed version for your release line: 0.3.2 or 0.4.0.

## Is CVE-2016-6298 being exploited?

There is no known exploitation of CVE-2016-6298 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-39373](https://insights.sbomify.com/CVE-2026-39373/): JWCrypto: JWE ZIP decompression bomb (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6298 and fix it if it is affected.

What it is: CVE-2016-6298 is a medium-severity vulnerability in n/a, published on 1 Sep 2016. 
Exploitation: There is no known exploitation of CVE-2016-6298 in the wild and no public exploit code.

Affected packages and fixed versions:
- jwcrypto (PyPI): affected all versions; fixed in 0.3.2
- jwcrypto (PyPI): affected all versions; fixed in 0.3.2
- jwcrypto (PyPI): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6298/ (Markdown: https://insights.sbomify.com/CVE-2016-6298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6298
- OSV: https://osv.dev/vulnerability/CVE-2016-6298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6298/
Summaries are generated and may contain mistakes; the official description above is the record.
