CVE-2016-6316 actionview Cross-site Scripting vulnerability
Remote attackers can inject arbitrary web script or HTML via text declared as HTML safe in Ruby on Rails Action View tag handlers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-6316?
CVE-2016-6316 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 7 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 might allow remote attackers to inject arbitrary web script or HTML via text declared as "HTML safe" and used as attribute values in tag handlers.
Weakness: CWE-79
Which versions are affected by CVE-2016-6316?
6 open source packages ship an affected version, including actionview. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
actionview RubyGems | From 3.0.0 | 3.2.22.3 |
actionview RubyGems | From 3.0.0 | 3.2.22.3 |
actionview RubyGems | From 4.0.0 | 4.2.7.1 |
actionview RubyGems | From 4.0.0 | 4.2.7.1 |
actionview RubyGems | From 5.0.0 | 5.0.0.1 |
actionview RubyGems | From 5.0.0 | 5.0.0.1 |
Linux distribution packages (12)
rh-ror41-rubygem-actionview Red Hat:rhel_software_collections:2::el6 | All versions | 0:4.1.5-6.el6 |
rh-ror41-rubygem-actionview-doc Red Hat:rhel_software_collections:2::el6 | All versions | 0:4.1.5-6.el6 |
ror40-rubygem-actionpack Red Hat:rhel_software_collections:2::el6 | All versions | 1:4.0.2-8.el6 |
ror40-rubygem-actionpack-doc Red Hat:rhel_software_collections:2::el6 | All versions | 1:4.0.2-8.el6 |
ruby193-rubygem-actionpack Red Hat:rhel_software_collections:2::el6 | All versions | 1:3.2.8-20.el6 |
ruby193-rubygem-actionpack-doc Red Hat:rhel_software_collections:2::el6 | All versions | 1:3.2.8-20.el6 |
rh-ror41-rubygem-actionview Red Hat:rhel_software_collections:2::el7 | All versions | 0:4.1.5-6.el7 |
rh-ror41-rubygem-actionview-doc Red Hat:rhel_software_collections:2::el7 | All versions | 0:4.1.5-6.el7 |
ror40-rubygem-actionpack Red Hat:rhel_software_collections:2::el7 | All versions | 1:4.0.2-8.el7 |
ror40-rubygem-actionpack-doc Red Hat:rhel_software_collections:2::el7 | All versions | 1:4.0.2-8.el7 |
ruby193-rubygem-actionpack Red Hat:rhel_software_collections:2::el7 | All versions | 1:3.2.8-20.el7 |
ruby193-rubygem-actionpack-doc Red Hat:rhel_software_collections:2::el7 | All versions | 1:3.2.8-20.el7 |
Products include Debian Debian Linux, Rubyonrails Rails, Rubyonrails Ruby on Rails.
How do I fix CVE-2016-6316?
Upgrade actionview to a fixed version for your release line: 3.2.22.3, 4.2.7.1 or 5.0.0.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-6316 being exploited?
There is no known exploitation of CVE-2016-6316 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2016-6316, DSA-3651-1, GHSA-pc3m-v286-2jwj, RHSA-2016:1856, RHSA-2016:1857, RHSA-2016:1858.