# CVE-2016-6317: ActiveRecord in Ruby on Rails allows database-query bypass

> Remote attackers can bypass database query restrictions and trigger missing WHERE clauses via crafted requests, potentially exposing or modifying data.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-6317, GHSA-pr3r-4wrp-r2pv

## What is CVE-2016-6317?

CVE-2016-6317 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Action Record in Ruby on Rails 4.2.x before 4.2.7.1 does not properly consider differences in parameter handling between the Active Record component and the JSON implementation, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks or trigger missing WHERE clauses via a crafted request, as demonstrated by certain "[nil]" values, a related issue to CVE-2012-2660, CVE-2012-2694, and CVE-2013-0155.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-6317?

2 open source packages ship an affected version, including activerecord. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 4.2.0 | 4.2.7.1 |
| `activerecord` | RubyGems | From 4.2.0 | 4.2.7.1 |

Products: Rubyonrails Rails.

## How do I fix CVE-2016-6317?

Upgrade activerecord to 4.2.7.1 or later.

## Is CVE-2016-6317 being exploited?

There is no known exploitation of CVE-2016-6317 in the wild and no public exploit code.

Public exploit code:

- https://github.com/kavgan/vuln_test_repo_public_ruby_gemfile_cve-2016-6317 (github_poc): https://github.com/kavgan/vuln_test_repo_public_ruby_gemfile_cve-2016-6317

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6317 and fix it if it is affected.

What it is: CVE-2016-6317 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6317 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 4.2.0; fixed in 4.2.7.1
- activerecord (RubyGems): affected from 4.2.0; fixed in 4.2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6317/ (Markdown: https://insights.sbomify.com/CVE-2016-6317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6317
- OSV: https://osv.dev/vulnerability/CVE-2016-6317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6317/
Summaries are generated and may contain mistakes; the official description above is the record.
