{"answers":{"affected":"2 open source packages ship an affected version, including org.jboss.resteasy:resteasy-jaxrs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-6346 in the wild and no public exploit code.","fix":"Upgrade org.jboss.resteasy:resteasy-jaxrs to 3.0.20.Final or later.","what":"CVE-2016-6346 is a high-severity denial of service vulnerability in n/a, published on 7 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-6346 and fix it if it is affected.\n\nWhat it is: CVE-2016-6346 is a high-severity denial of service vulnerability in n/a, published on 7 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-6346 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jboss.resteasy:resteasy-jaxrs (Maven): affected all versions; fixed in 3.0.20.Final\n- org.jboss.resteasy:resteasy-jaxrs (Maven): affected all versions; fixed in 3.0.20.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6346/ (Markdown: https://insights.sbomify.com/CVE-2016-6346/index.md)","id":"CVE-2016-6346","markdown":"https://insights.sbomify.com/CVE-2016-6346/index.md","name":"CVE-2016-6346","record":{"aliases":["DEBIAN-CVE-2016-6346","GHSA-wxvr-vqfp-9cqw","UBUNTU-CVE-2016-6346"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Java REST framework","requires_auth":"none","summary":"Remote attackers can cause a denial of service in RESTEasy applications by exploiting the GZIPInterceptor feature.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"resteasy","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[],"description":"RESTEasy enables GZIPInterceptor, which allows remote attackers to cause a denial of service via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in JBoss resteasy","id":"CVE-2016-6346","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":2,"n_references":15,"next":{"headline":"Improper Neutralization of Input During Web Page Generation in RESTEasy","id":"CVE-2016-6347"},"packages":[{"ecosystem":"Maven","fixed":["3.0.20.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.resteasy:resteasy-jaxrs","purl":null,"source":"GHSA-wxvr-vqfp-9cqw"},{"ecosystem":"Maven","fixed":["3.0.20.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.resteasy:resteasy-jaxrs","purl":"pkg:maven/org.jboss.resteasy/resteasy-jaxrs","source":"GHSA-wxvr-vqfp-9cqw"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in RESTEasy","id":"CVE-2016-6345"},"products":["n/a"],"published":"2016-09-07","related":[{"cvss_score":8.1,"headline":"JBoss RESTEasy vulnerable to Improper Input Validation","id":"CVE-2016-9606","kev_date_added":null,"published":"2018-03-09"},{"cvss_score":8.1,"headline":"Deserialization of Untrusted Data in org.jboss.resteasy:resteasy-yaml-provider","id":"CVE-2018-1051","kev_date_added":null,"published":"2018-01-25"},{"cvss_score":6.5,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in RESTEasy","id":"CVE-2016-6345","kev_date_added":null,"published":"2016-09-07"},{"cvss_score":6.4,"headline":"XML External Entity Reference in RESTEasy","id":"CVE-2014-7839","kev_date_added":null,"published":"2014-11-25"},{"cvss_score":6.1,"headline":"Improper Neutralization of Input During Web Page Generation in RESTEasy","id":"CVE-2016-6347","kev_date_added":null,"published":"2017-04-20"},{"cvss_score":6.1,"headline":"JacksonJsonpInterceptor susceptible to cross-site script inclusion (XSSI) attack","id":"CVE-2016-6348","kev_date_added":null,"published":"2017-04-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in RESTEasy applications by exploiting the GZIPInterceptor feature.","url":"https://insights.sbomify.com/CVE-2016-6346/"}