# CVE-2016-6360: Denial of service in Cisco AsyncOS through WSA10.0.0-000

> Unauthenticated remote attackers can cause a partial denial of service by triggering an unexpected restart of the Advanced Malware Protection process on Cisco security appliances.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wj9f-9jrq-c6wp

## What is CVE-2016-6360?

CVE-2016-6360 is a high-severity denial of service vulnerability in Cisco Email Security Appliance, published on 28 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in Advanced Malware Protection (AMP) for Cisco Email Security Appliances (ESA) and Web Security Appliances (WSA) could allow an unauthenticated, remote attacker to cause a partial denial of service (DoS) condition due to the AMP process unexpectedly restarting. Affected Products: Cisco AsyncOS Software for Email Security Appliances (ESA) versions 9.5 and later up to the first fixed release, Cisco AsyncOS Software for Web Security Appliances (WSA) all versions prior to the first fixed release. More Information: CSCux56406, CSCux59928. Known Affected Releases: 9.6.0-051 9.7.0-125 8.8.0-085 9.5.0-444 WSA10.0.0-000. Known Fixed Releases: 9.7.1-066 WSA10.0.0-233.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-6360?

It affects 2 products.


Products: Cisco Email Security Appliance, Cisco Web Security Appliance.

## How do I fix CVE-2016-6360?

No fix has been published for CVE-2016-6360 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-6360 being exploited?

There is no known exploitation of CVE-2016-6360 in the wild and no public exploit code.

## Other vulnerabilities in Cisco Email Security Appliance

- [CVE-2022-20798](https://insights.sbomify.com/CVE-2022-20798/): Cisco Email Security Appliance and Cisco Secure Email and Web Manager External Authentication Bypass Vulnerability (critical 9.8)
- [CVE-2015-6291](https://insights.sbomify.com/CVE-2015-6291/): Denial of service in n/a (high 7.8)
- [CVE-2022-20664](https://insights.sbomify.com/CVE-2022-20664/): Cisco Email Security Appliance and Cisco Secure Email and Web Manager Information Disclosure Vulnerability (high 7.7)
- [CVE-2022-20960](https://insights.sbomify.com/CVE-2022-20960/): Denial of service in Cisco Secure Email (high 7.5)
- [CVE-2018-0419](https://insights.sbomify.com/CVE-2018-0419/): Security feature bypass in Email Security Appliance (ESA) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6360 and fix it if it is affected.

What it is: CVE-2016-6360 is a high-severity denial of service vulnerability in Cisco Email Security Appliance, published on 28 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6360 in the wild and no public exploit code.

Affected product: Cisco Email Security Appliance. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6360/ (Markdown: https://insights.sbomify.com/CVE-2016-6360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6360
- OSV: https://osv.dev/vulnerability/CVE-2016-6360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6360/
Summaries are generated and may contain mistakes; the official description above is the record.
