CVE-2016-6437 Denial of service in Cisco Wide Area Application Services (WAAS) before 5.3(5g)1 and 6.x before 6.2(2.32)

Medium 5.9 Published Updated

Unauthenticated remote attackers can cause denial of service in Cisco WAAS by exhausting disk space via SSL session cache management.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2016-6437?

CVE-2016-6437 is a medium-severity denial of service vulnerability in Cisco Wide Area Application Services (WAAS) before 5.3(5g)1 and 6.x before 6.2(2.32), published on 27 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability in the SSL session cache management of Cisco Wide Area Application Services (WAAS) could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition due to high consumption of disk space. The user would see a performance degradation. More Information: CSCva03095. Known Affected Releases: 5.3(5), 6.1(1), 6.2(1). Known Fixed Releases: 5.3(5g)1, 6.2(2.32).

Weakness: CWE-399

Which versions are affected by CVE-2016-6437?

It affects 1 product.

Products include Cisco Wide Area Application Services.

How do I fix CVE-2016-6437?

No fix has been published for CVE-2016-6437 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2016-6437 being exploited?

There is no known exploitation of CVE-2016-6437 in the wild and no public exploit code.

Sources

Also known as GHSA-mpwr-fprg-72gv.

Is CVE-2016-6437 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free