# CVE-2016-6437: Denial of service in Cisco Wide Area Application Services (WAAS) before 5.3(5g)1 and 6.x before 6.2(2.32)

> Unauthenticated remote attackers can cause denial of service in Cisco WAAS by exhausting disk space via SSL session cache management.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mpwr-fprg-72gv

## What is CVE-2016-6437?

CVE-2016-6437 is a medium-severity denial of service vulnerability in Cisco Wide Area Application Services (WAAS) before 5.3(5g)1 and 6.x before 6.2(2.32), published on 27 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the SSL session cache management of Cisco Wide Area Application Services (WAAS) could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition due to high consumption of disk space. The user would see a performance degradation. More Information: CSCva03095. Known Affected Releases: 5.3(5), 6.1(1), 6.2(1). Known Fixed Releases: 5.3(5g)1, 6.2(2.32).

Weakness: CWE-399

## Which versions are affected by CVE-2016-6437?

It affects 1 product.


Products: Cisco Wide Area Application Services.

## How do I fix CVE-2016-6437?

No fix has been published for CVE-2016-6437 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-6437 being exploited?

There is no known exploitation of CVE-2016-6437 in the wild and no public exploit code.

## Other vulnerabilities in Cisco Wide Area Application Services (WAAS) before 5.3(5g)1 and 6.x before 6.2(2.32)

- [CVE-2013-3443](https://insights.sbomify.com/CVE-2013-3443/): Code injection in n/a (critical 10.0)
- [CVE-2014-2196](https://insights.sbomify.com/CVE-2014-2196/): Code injection in n/a (critical 9.3)
- [CVE-2007-3923](https://insights.sbomify.com/CVE-2007-3923/): Denial of service in n/a (high 7.8)
- [CVE-2015-6421](https://insights.sbomify.com/CVE-2015-6421/): Denial of service in n/a (high 7.5)
- [CVE-2017-6628](https://insights.sbomify.com/CVE-2017-6628/): Denial of service in Cisco Wide Area Application Services SMART-SSL Accelerator (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6437 and fix it if it is affected.

What it is: CVE-2016-6437 is a medium-severity denial of service vulnerability in Cisco Wide Area Application Services (WAAS) before 5.3(5g)1 and 6.x before 6.2(2.32), published on 27 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6437 in the wild and no public exploit code.

Affected product: Cisco Wide Area Application Services (WAAS) before 5.3(5g)1 and 6.x before 6.2(2.32). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6437/ (Markdown: https://insights.sbomify.com/CVE-2016-6437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6437
- OSV: https://osv.dev/vulnerability/CVE-2016-6437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6437/
Summaries are generated and may contain mistakes; the official description above is the record.
