{"answers":{"affected":"3 open source packages ship an affected version, including manila-ui. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-6519 in the wild and no public exploit code.","fix":"Upgrade manila-ui to 2.5.1 or later.","what":"CVE-2016-6519 is a medium-severity cross-site scripting vulnerability in Redhat Openstack, published on 21 Apr 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-6519 and fix it if it is affected.\n\nWhat it is: CVE-2016-6519 is a medium-severity cross-site scripting vulnerability in Redhat Openstack, published on 21 Apr 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-6519 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- manila-ui (PyPI): affected all versions; fixed in 2.5.1\n- manila-ui (PyPI): affected all versions; fixed in 2.5.1\n- manila-ui (PyPI): affected all versions; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6519/ (Markdown: https://insights.sbomify.com/CVE-2016-6519/index.md)","id":"CVE-2016-6519","markdown":"https://insights.sbomify.com/CVE-2016-6519/index.md","name":"CVE-2016-6519","record":{"aliases":["DEBIAN-CVE-2016-6519","GHSA-vq76-5ghr-9p4v","PYSEC-2026-662","RHSA-2016:2115","RHSA-2016:2116","RHSA-2016:2117","SUSE-SU-2016:2457-1","UBUNTU-CVE-2016-6519"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenStack Manila","requires_auth":"low_privilege","summary":"Authenticated users can inject arbitrary scripts via the Metadata field in the Create Share form, potentially compromising other users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"manila","vendor":"openstack"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the \"Shares\" overview in Openstack Manila before 2.5.1 allows remote authenticated users to inject arbitrary web script or HTML via the Metadata field in the \"Create Share\" form.","ecosystems":["PyPI","Red Hat:openstack:7::el7","Red Hat:openstack:8::el7","Red Hat:openstack:9::el7","SUSE:OpenStack Cloud 6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Openstack Manila Persistent XSS in Metadata field","id":"CVE-2016-6519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:openstack","products":["redhat:openstack"],"type":"xss","year":"2016"},"n_packages":7,"n_references":7,"next":{"headline":"Memory corruption in n/a","id":"CVE-2016-6520"},"packages":[{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"manila-ui","purl":null,"source":"GHSA-vq76-5ghr-9p4v"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"manila-ui","purl":"pkg:pypi/manila-ui","source":"GHSA-vq76-5ghr-9p4v"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"manila-ui","purl":"pkg:pypi/manila-ui","source":"PYSEC-2026-662"},{"ecosystem":"Red Hat:openstack:7::el7","fixed":["0:1.0.1-3.el7ost"],"introduced":["0"],"last_affected":[],"package":"openstack-manila-ui","purl":"pkg:rpm/redhat/openstack-manila-ui","source":"RHSA-2016:2115"},{"ecosystem":"Red Hat:openstack:8::el7","fixed":["0:1.2.0-2.el7ost"],"introduced":["0"],"last_affected":[],"package":"openstack-manila-ui","purl":"pkg:rpm/redhat/openstack-manila-ui","source":"RHSA-2016:2116"},{"ecosystem":"Red Hat:openstack:9::el7","fixed":["0:2.1.0-2.el7ost"],"introduced":["0"],"last_affected":[],"package":"openstack-manila-ui","purl":"pkg:rpm/redhat/openstack-manila-ui","source":"RHSA-2016:2117"},{"ecosystem":"SUSE:OpenStack Cloud 6","fixed":["1.2.1~a0~dev2-3.1"],"introduced":["0"],"last_affected":[],"package":"openstack-horizon-plugin-manila-ui","purl":"pkg:rpm/suse/openstack-horizon-plugin-manila-ui\u0026distro=SUSE%20OpenStack%20Cloud%206","source":"SUSE-SU-2016:2457-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-6518"},"products":["n/a"],"published":"2017-04-21","related":[{"cvss_score":8.3,"headline":"OpenStack Manila Unprivileged users can retrieve, use and manipulate share networks","id":"CVE-2020-9543","kev_date_added":null,"published":"2020-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can inject arbitrary scripts via the Metadata field in the Create Share form, potentially compromising other users' sessions.","url":"https://insights.sbomify.com/CVE-2016-6519/"}