CVE-2016-6556 OpenNMS Stored XSS via SNMP Agent Data

High 7.1 Published Updated

Attackers can inject malicious scripts via SNMP responses that execute in the OpenNMS web UI, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2016-6556?

CVE-2016-6556 is a high-severity cross-site scripting vulnerability in OpenNMS, published on 15 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

OpenNMS version 18.0.1 and prior are vulnerable to a stored XSS issue due to insufficient filtering of SNMP agent supplied data. By creating a malicious SNMP 'sysName' or 'sysContact' response, an attacker can store an XSS payload which will trigger when a user of the web UI views the data. This issue was fixed in version 18.0.2, released on September 20, 2016.

Weakness: CWE-79

Which versions are affected by CVE-2016-6556?

It affects 1 product.

Products include Opennms Opennms.

How do I fix CVE-2016-6556?

No fix has been published for CVE-2016-6556 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2016-6556 being exploited?

There is no known exploitation of CVE-2016-6556 in the wild and no public exploit code.

Sources

Also known as GHSA-gg9p-hvqm-vj23.

Is CVE-2016-6556 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free