{"answers":{"affected":"3 open source packages ship an affected version, including priority. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-6580 in the wild and no public exploit code.","fix":"Upgrade priority to 1.2.0 or later.","what":"CVE-2016-6580 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-6580 and fix it if it is affected.\n\nWhat it is: CVE-2016-6580 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-6580 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- priority (PyPI): affected all versions; fixed in 1.2.0\n- priority (PyPI): affected all versions; fixed in 1.2.0\n- priority (PyPI): affected all versions; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6580/ (Markdown: https://insights.sbomify.com/CVE-2016-6580/index.md)","id":"CVE-2016-6580","markdown":"https://insights.sbomify.com/CVE-2016-6580/index.md","name":"CVE-2016-6580","record":{"aliases":["GHSA-h3q4-6j7f-r24c","PYSEC-2017-93"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python HTTP/2 library","requires_auth":"none","summary":"A malicious peer can cause memory exhaustion and high CPU usage in HTTP/2 implementations using the Python priority library by assigning priority to all stream IDs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"python_priority_library","vendor":"python"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"A HTTP/2 implementation built using any version of the Python priority library prior to version 1.2.0 could be targeted by a malicious peer by having that peer assign priority information for every possible HTTP/2 stream ID. The priority tree would happily continue to store the priority information for each stream, and would therefore allocate unbounded amounts of memory. Attempting to actually use a tree like this would also cause extremely high CPU usage to maintain the tree.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"priority vulnerable to denial of service","id":"CVE-2016-6580","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":3,"n_references":2,"next":{"headline":"HPACK Denial of Service vulnerability (HPACK Bomb)","id":"CVE-2016-6581"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"priority","purl":null,"source":"GHSA-h3q4-6j7f-r24c"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"priority","purl":"pkg:pypi/priority","source":"GHSA-h3q4-6j7f-r24c"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"priority","purl":"pkg:pypi/priority","source":"PYSEC-2017-93"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-6579"},"products":["n/a"],"published":"2017-01-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A malicious peer can cause memory exhaustion and high CPU usage in HTTP/2 implementations using the Python priority library by assigning priority to all stream IDs.","url":"https://insights.sbomify.com/CVE-2016-6580/"}