# CVE-2016-6580: priority vulnerable to denial of service

> A malicious peer can cause memory exhaustion and high CPU usage in HTTP/2 implementations using the Python priority library by assigning priority to all stream IDs.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h3q4-6j7f-r24c, PYSEC-2017-93

## What is CVE-2016-6580?

CVE-2016-6580 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A HTTP/2 implementation built using any version of the Python priority library prior to version 1.2.0 could be targeted by a malicious peer by having that peer assign priority information for every possible HTTP/2 stream ID. The priority tree would happily continue to store the priority information for each stream, and would therefore allocate unbounded amounts of memory. Attempting to actually use a tree like this would also cause extremely high CPU usage to maintain the tree.

Weakness: CWE-399

## Which versions are affected by CVE-2016-6580?

3 open source packages ship an affected version, including priority. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `priority` | PyPI | All versions | 1.2.0 |
| `priority` | PyPI | All versions | 1.2.0 |
| `priority` | PyPI | All versions | 1.2.0 |

Products: Python Python Priority Library.

## How do I fix CVE-2016-6580?

Upgrade priority to 1.2.0 or later.

## Is CVE-2016-6580 being exploited?

There is no known exploitation of CVE-2016-6580 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6580 and fix it if it is affected.

What it is: CVE-2016-6580 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6580 in the wild and no public exploit code.

Affected packages and fixed versions:
- priority (PyPI): affected all versions; fixed in 1.2.0
- priority (PyPI): affected all versions; fixed in 1.2.0
- priority (PyPI): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6580/ (Markdown: https://insights.sbomify.com/CVE-2016-6580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6580
- OSV: https://osv.dev/vulnerability/CVE-2016-6580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6580/
Summaries are generated and may contain mistakes; the official description above is the record.
