CVE-2016-6581 HPACK Denial of Service vulnerability (HPACK Bomb)
Attackers can cause denial of service in HTTP/2 implementations using the Python HPACK library by exploiting a compression ratio vulnerability known as the HPACK Bomb.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-6581?
CVE-2016-6581 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A HTTP/2 implementation built using any version of the Python HPACK library between v1.0.0 and v2.2.0 could be targeted for a denial of service attack, specifically a so-called "HPACK Bomb" attack. This attack occurs when an attacker inserts a header field that is exactly the size of the HPACK dynamic header table into the dynamic header table. The attacker can then send a header block that is simply repeated requests to expand that field in the dynamic table. This can lead to a gigantic compression ratio of 4,096 or better, meaning that 16kB of data can decompress to 64MB of data on the target machine.
Weakness: CWE-399
Which versions are affected by CVE-2016-6581?
3 open source packages ship an affected version, including hpack. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
hpack PyPI | All versions | 2.3.0 |
hpack PyPI | From 1.0.0 | 2.3.0 |
hpack PyPI | From 1.0.0 | 2.3.0 |
Linux distribution packages (1)
python-hpack openSUSE:Tumbleweed | All versions | 4.0.0-2.7 |
Products include Python Hpack, Python Hyper.
How do I fix CVE-2016-6581?
Upgrade hpack to 2.3.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-6581 being exploited?
There is no known exploitation of CVE-2016-6581 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2016-6581, GHSA-ffq8-576r-v26g, PYSEC-2017-87, UBUNTU-CVE-2016-6581, openSUSE-SU-2024:11230-1, openSUSE-SU-2024:14140-1.