{"answers":{"affected":"3 open source packages ship an affected version, including hpack. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-6581 in the wild and no public exploit code.","fix":"Upgrade hpack to 2.3.0 or later.","what":"CVE-2016-6581 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-6581 and fix it if it is affected.\n\nWhat it is: CVE-2016-6581 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-6581 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hpack (PyPI): affected all versions; fixed in 2.3.0\n- hpack (PyPI): affected from 1.0.0; fixed in 2.3.0\n- hpack (PyPI): affected from 1.0.0; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6581/ (Markdown: https://insights.sbomify.com/CVE-2016-6581/index.md)","id":"CVE-2016-6581","markdown":"https://insights.sbomify.com/CVE-2016-6581/index.md","name":"CVE-2016-6581","record":{"aliases":["DEBIAN-CVE-2016-6581","GHSA-ffq8-576r-v26g","PYSEC-2017-87","UBUNTU-CVE-2016-6581","openSUSE-SU-2024:11230-1","openSUSE-SU-2024:14140-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python HPACK library","requires_auth":"none","summary":"Attackers can cause denial of service in HTTP/2 implementations using the Python HPACK library by exploiting a compression ratio vulnerability known as the HPACK Bomb.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"hpack","vendor":"python"},{"product":"hyper","vendor":"python"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"A HTTP/2 implementation built using any version of the Python HPACK library between v1.0.0 and v2.2.0 could be targeted for a denial of service attack, specifically a so-called \"HPACK Bomb\" attack. This attack occurs when an attacker inserts a header field that is exactly the size of the HPACK dynamic header table into the dynamic header table. The attacker can then send a header block that is simply repeated requests to expand that field in the dynamic table. This can lead to a gigantic compression ratio of 4,096 or better, meaning that 16kB of data can decompress to 64MB of data on the target machine.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HPACK Denial of Service vulnerability (HPACK Bomb)","id":"CVE-2016-6581","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":4,"n_references":2,"next":{"headline":"Doorkeeper is vulnerable to replay attacks","id":"CVE-2016-6582"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"hpack","purl":"pkg:pypi/hpack","source":"PYSEC-2017-87"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["1.0.0"],"last_affected":[],"package":"hpack","purl":null,"source":"GHSA-ffq8-576r-v26g"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["1.0.0"],"last_affected":[],"package":"hpack","purl":"pkg:pypi/hpack","source":"GHSA-ffq8-576r-v26g"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.0.0-2.7"],"introduced":["0"],"last_affected":[],"package":"python-hpack","purl":"pkg:rpm/opensuse/python-hpack\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14140-1"}],"prev":{"headline":"priority vulnerable to denial of service","id":"CVE-2016-6580"},"products":["n/a"],"published":"2017-01-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can cause denial of service in HTTP/2 implementations using the Python HPACK library by exploiting a compression ratio vulnerability known as the HPACK Bomb.","url":"https://insights.sbomify.com/CVE-2016-6581/"}