# CVE-2016-6581: HPACK Denial of Service vulnerability (HPACK Bomb)

> Attackers can cause denial of service in HTTP/2 implementations using the Python HPACK library by exploiting a compression ratio vulnerability known as the HPACK Bomb.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-6581, GHSA-ffq8-576r-v26g, PYSEC-2017-87, UBUNTU-CVE-2016-6581, openSUSE-SU-2024:11230-1, openSUSE-SU-2024:14140-1

## What is CVE-2016-6581?

CVE-2016-6581 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A HTTP/2 implementation built using any version of the Python HPACK library between v1.0.0 and v2.2.0 could be targeted for a denial of service attack, specifically a so-called "HPACK Bomb" attack. This attack occurs when an attacker inserts a header field that is exactly the size of the HPACK dynamic header table into the dynamic header table. The attacker can then send a header block that is simply repeated requests to expand that field in the dynamic table. This can lead to a gigantic compression ratio of 4,096 or better, meaning that 16kB of data can decompress to 64MB of data on the target machine.

Weakness: CWE-399

## Which versions are affected by CVE-2016-6581?

3 open source packages ship an affected version, including hpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hpack` | PyPI | All versions | 2.3.0 |
| `hpack` | PyPI | From 1.0.0 | 2.3.0 |
| `hpack` | PyPI | From 1.0.0 | 2.3.0 |
| `python-hpack` | openSUSE:Tumbleweed | All versions | 4.0.0-2.7 |

Products: Python Hpack, Python Hyper.

## How do I fix CVE-2016-6581?

Upgrade hpack to 2.3.0 or later.

## Is CVE-2016-6581 being exploited?

There is no known exploitation of CVE-2016-6581 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6581 and fix it if it is affected.

What it is: CVE-2016-6581 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6581 in the wild and no public exploit code.

Affected packages and fixed versions:
- hpack (PyPI): affected all versions; fixed in 2.3.0
- hpack (PyPI): affected from 1.0.0; fixed in 2.3.0
- hpack (PyPI): affected from 1.0.0; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6581/ (Markdown: https://insights.sbomify.com/CVE-2016-6581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6581
- OSV: https://osv.dev/vulnerability/CVE-2016-6581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6581/
Summaries are generated and may contain mistakes; the official description above is the record.
