CVE-2016-6582 Doorkeeper is vulnerable to replay attacks
Critical 9.1
Published
Updated
Check this codebase for CVE-2016-6582 and fix it if it is affected.
What it is: CVE-2016-6582 is a critical vulnerability in n/a, published on 23 Jan 2017.
Exploitation: There is no known exploitation of CVE-2016-6582 in the wild and no public exploit code.
Affected packages and fixed versions:
- doorkeeper (RubyGems): affected all versions; fixed in 4.2.0
- doorkeeper (RubyGems): affected all versions; fixed in 4.2.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2016-6582/ (Markdown: https://insights.sbomify.com/CVE-2016-6582/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2016-6582?
CVE-2016-6582 is a critical vulnerability in n/a, published on 23 Jan 2017.
Official description
The Doorkeeper gem before 4.2.0 for Ruby might allow remote attackers to conduct replay attacks or revoke arbitrary tokens by leveraging failure to implement the OAuth 2.0 Token Revocation specification.
Weakness: CWE-254
Which versions are affected by CVE-2016-6582?
2 open source packages ship an affected version, including doorkeeper. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
doorkeeper RubyGems | All versions | 4.2.0 |
doorkeeper RubyGems | All versions | 4.2.0 |
Products include Doorkeeper Project Doorkeeper.
How do I fix CVE-2016-6582?
Upgrade doorkeeper to 4.2.0 or later.
Is CVE-2016-6582 being exploited?
There is no known exploitation of CVE-2016-6582 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2020-10187 Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper
- CVE-2018-1000211 Doorkeeper subject to Incorrect Permission Assignment
- CVE-2014-8144 Doorkeeper vulnerable to Cross-site Request Forgery
- CVE-2018-1000088 Doorkeeper is vulnerable to stored XSS and code execution
- CVE-2023-34246 Doorkeeper Improper Authentication vulnerability
Sources
Also known as DEBIAN-CVE-2016-6582, GHSA-3m6r-39p3-jq25, UBUNTU-CVE-2016-6582.