CVE-2016-6608 phpMyAdmin Cross-site Scripting (XSS)

Medium 6.1 Published Updated

Cross-site scripting in phpMyAdmin allows attackers to execute scripts via crafted database names, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-6608?

CVE-2016-6608 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

XSS issues were discovered in phpMyAdmin. This affects the database privilege check and the "Remove partitioning" functionality. Specially crafted database names can trigger the XSS attack. All 4.6.x versions (prior to 4.6.4) are affected.

Weakness: CWE-79

Which versions are affected by CVE-2016-6608?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.

PackageAffectedFixed in
phpmyadmin/phpmyadmin PackagistFrom 4.64.6.4
phpmyadmin/phpmyadmin PackagistFrom 4.64.6.4

Products include Phpmyadmin Phpmyadmin.

How do I fix CVE-2016-6608?

Upgrade phpmyadmin/phpmyadmin to 4.6.4 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2016-6608 being exploited?

There is no known exploitation of CVE-2016-6608 in the wild and no public exploit code.

All Phpmyadmin Phpmyadmin vulnerabilities

Sources

Also known as ALPINE-CVE-2016-6608, DEBIAN-CVE-2016-6608, GHSA-jfmj-27fp-qp67.

Is CVE-2016-6608 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free