CVE-2016-6609 phpMyAdmin PHP code injection
Attackers can execute arbitrary PHP commands via crafted database names in the array export feature of phpMyAdmin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-6609?
CVE-2016-6609 is a high-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin. A specially crafted database name could be used to run arbitrary PHP commands through the array export feature. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Weakness: CWE-77
Which versions are affected by CVE-2016-6609?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-6609?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.17, 4.4.15.8 or 4.6.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2016-6609 being exploited?
There is no known exploitation of CVE-2016-6609 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-6609, DEBIAN-CVE-2016-6609, GHSA-wpww-hx7x-xfjh, UBUNTU-CVE-2016-6609.