CVE-2016-6612 phpMyAdmin Local file exposure
An attacker can exploit LOAD LOCAL INFILE in phpMyAdmin to expose server files to the database system, leading to information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-6612?
CVE-2016-6612 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin. A user can exploit the LOAD LOCAL INFILE functionality to expose files on the server to the database system. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Weakness: CWE-200
Which versions are affected by CVE-2016-6612?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-6612?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.17, 4.4.15.8 or 4.6.4.
Is CVE-2016-6612 being exploited?
There is no known exploitation of CVE-2016-6612 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-6612, DEBIAN-CVE-2016-6612, GHSA-fcgm-62p3-f7cm, UBUNTU-CVE-2016-6612.