CVE-2016-6621 phpMyAdmin server-side request forgery (SSRF)
Remote attackers can conduct server-side request forgery attacks via the setup script, potentially accessing internal resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-6621?
CVE-2016-6621 is a high-severity server-side request forgery vulnerability in Phpmyadmin Phpmyadmin, published on 31 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.
Weakness: CWE-918
Which versions are affected by CVE-2016-6621?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | All versions | 4.0.10.19 |
phpmyadmin/phpmyadmin Packagist | All versions | 4.0.10.19 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.10 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.10 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.6 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.6 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-6621?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.19, 4.4.15.10 or 4.6.6.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2016-6621 being exploited?
There is no known exploitation of CVE-2016-6621 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2016-6621, DLA-834-1, GHSA-44vv-mm86-7cg6, UBUNTU-CVE-2016-6621.