# CVE-2016-6621: phpMyAdmin server-side request forgery (SSRF)

> Remote attackers can conduct server-side request forgery attacks via the setup script, potentially accessing internal resources.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-6621, DLA-834-1, GHSA-44vv-mm86-7cg6, UBUNTU-CVE-2016-6621

## What is CVE-2016-6621?

CVE-2016-6621 is a high-severity server-side request forgery vulnerability in Phpmyadmin Phpmyadmin, published on 31 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The setup script for phpMyAdmin before 4.0.10.19, 4.4.x before 4.4.15.10, and 4.6.x before 4.6.6 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2016-6621?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.0.10.19 |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.0.10.19 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.0 | 4.4.15.10 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4.0 | 4.4.15.10 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.6 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.6 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-6621?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.19, 4.4.15.10 or 4.6.6.

## Is CVE-2016-6621 being exploited?

There is no known exploitation of CVE-2016-6621 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6621 and fix it if it is affected.

What it is: CVE-2016-6621 is a high-severity server-side request forgery vulnerability in Phpmyadmin Phpmyadmin, published on 31 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6621 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.0.10.19
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.0.10.19
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.15.10
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.15.10
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.6
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6621/ (Markdown: https://insights.sbomify.com/CVE-2016-6621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6621
- OSV: https://osv.dev/vulnerability/CVE-2016-6621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6621/
Summaries are generated and may contain mistakes; the official description above is the record.
