CVE-2016-6624 phpMyAdmin IPv6 and proxy server IP-based authentication rule circumvention
Attackers can bypass IP-based authentication rules in phpMyAdmin when using IPv6 behind a proxy, allowing unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-6624?
CVE-2016-6624 is a medium-severity authentication bypass vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin involving improper enforcement of the IP-based authentication rules. When phpMyAdmin is used with IPv6 in a proxy server environment, and the proxy server is in the allowed range but the attacking computer is not allowed, this vulnerability can allow the attacking computer to connect despite the IP rules. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Weakness: CWE-254
Which versions are affected by CVE-2016-6624?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-6624?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.17, 4.4.15.8 or 4.6.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2016-6624 being exploited?
There is no known exploitation of CVE-2016-6624 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-6624, DEBIAN-CVE-2016-6624, GHSA-mhxj-6vf8-mwv3, UBUNTU-CVE-2016-6624.