# CVE-2016-6628: phpMyAdmin Reflected File Download attack

> An attacker can trick users into downloading malicious SVG files in phpMyAdmin, potentially leading to script execution or account compromise.

- **Severity:** Medium 6.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** ALPINE-CVE-2016-6628, DEBIAN-CVE-2016-6628, GHSA-phhm-63xx-v9rr, UBUNTU-CVE-2016-6628

## What is CVE-2016-6628?

CVE-2016-6628 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in phpMyAdmin. An attacker may be able to trigger a user to download a specially crafted malicious SVG file. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.

Weakness: CWE-254

## Which versions are affected by CVE-2016-6628?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.17 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.17 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.8 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.8 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6 | 4.6.4 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6 | 4.6.4 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-6628?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.17, 4.4.15.8 or 4.6.4.

## Is CVE-2016-6628 being exploited?

There is no known exploitation of CVE-2016-6628 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6628 and fix it if it is affected.

What it is: CVE-2016-6628 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-6628 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.17
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.17
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.8
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.8
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.4
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6628/ (Markdown: https://insights.sbomify.com/CVE-2016-6628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6628
- OSV: https://osv.dev/vulnerability/CVE-2016-6628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6628/
Summaries are generated and may contain mistakes; the official description above is the record.
