CVE-2016-6632 phpMyAdmin Denial of service (DOS) attack with dbase extension
phpMyAdmin fails to delete temporary files during ESRI file imports, potentially leading to disk space exhaustion and denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-6632?
CVE-2016-6632 is a medium-severity denial of service vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpMyAdmin where, under certain conditions, phpMyAdmin may not delete temporary files during the import of ESRI files. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Weakness: CWE-399
Which versions are affected by CVE-2016-6632?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.17 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.8 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.4 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-6632?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.17, 4.4.15.8 or 4.6.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-6632 being exploited?
There is no known exploitation of CVE-2016-6632 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as ALPINE-CVE-2016-6632, DEBIAN-CVE-2016-6632, GHSA-426q-975p-w5cr, UBUNTU-CVE-2016-6632.