CVE-2016-6637 Cloud Foundry vulnerable to Cross-Site Request Forgery
Attackers can hijack user authentication to approve or deny scopes via CSRF in Pivotal Cloud Foundry UAA and related components.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-6637?
CVE-2016-6637 is a critical vulnerability in n/a, published on 30 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3.0.5, and 3.4.x before 3.4.4; UAA BOSH before 11.5 and 12.x before 12.5; Elastic Runtime before 1.6.40, 1.7.x before 1.7.21, and 1.8.x before 1.8.2; and Ops Manager 1.7.x before 1.7.13 and 1.8.x before 1.8.1 allow remote attackers to hijack the authentication of unspecified victims for requests that approve or deny a scope via a profile or authorize approval page.
Weakness: CWE-352
Which versions are affected by CVE-2016-6637?
8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 2.0.0 | 2.7.4.7 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 2.0.0 | 2.7.4.7 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.3.0.5 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.3.0.5 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.4.0 | 3.4.4 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.4.0 | 3.4.4 |
2 more packages
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.5.0 | 3.7.0 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.5.0 | 3.7.0 |
Products include Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry, Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Ops Manager, Pivotal Software Cloud Foundry Uaa.
How do I fix CVE-2016-6637?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 2.7.4.7, 3.3.0.5, 3.4.4 or 3.7.0.
Is CVE-2016-6637 being exploited?
There is no known exploitation of CVE-2016-6637 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2017-4973 Cloud Foundry UAA Privilege Escalation
- CVE-2016-4468 SQL injection in n/a
- CVE-2016-6651 Privilege escalation in n/a
- CVE-2016-3084 Cloud Foundry UAA reset password vulnerable to brute force attack
- CVE-2016-6659 Privilege escalation in Cloud Foundry v247 and earlier and UAA v3.9.2 & earlier and UAA bosh (uaa-release) v23 & earlier
Sources
Also known as GHSA-4m8c-h7fr-gq5c.