# CVE-2016-6637: Cloud Foundry vulnerable to Cross-Site Request Forgery

> Attackers can hijack user authentication to approve or deny scopes via CSRF in Pivotal Cloud Foundry UAA and related components.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4m8c-h7fr-gq5c

## What is CVE-2016-6637?

CVE-2016-6637 is a critical vulnerability in n/a, published on 30 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3.0.5, and 3.4.x before 3.4.4; UAA BOSH before 11.5 and 12.x before 12.5; Elastic Runtime before 1.6.40, 1.7.x before 1.7.21, and 1.8.x before 1.8.2; and Ops Manager 1.7.x before 1.7.13 and 1.8.x before 1.8.1 allow remote attackers to hijack the authentication of unspecified victims for requests that approve or deny a scope via a profile or authorize approval page.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2016-6637?

8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.7 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.7 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.3.0.5 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.3.0.5 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.4.0 | 3.4.4 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.4.0 | 3.4.4 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.5.0 | 3.7.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.5.0 | 3.7.0 |

Products: Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry, Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Ops Manager, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2016-6637?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 2.7.4.7, 3.3.0.5, 3.4.4 or 3.7.0.

## Is CVE-2016-6637 being exploited?

There is no known exploitation of CVE-2016-6637 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-4973](https://insights.sbomify.com/CVE-2017-4973/): Cloud Foundry UAA Privilege Escalation (high 8.8)
- [CVE-2016-4468](https://insights.sbomify.com/CVE-2016-4468/): SQL injection in n/a (high 8.8)
- [CVE-2016-6651](https://insights.sbomify.com/CVE-2016-6651/): Privilege escalation in n/a (high 8.8)
- [CVE-2016-3084](https://insights.sbomify.com/CVE-2016-3084/): Cloud Foundry UAA reset password vulnerable to brute force attack (high 8.1)
- [CVE-2016-6659](https://insights.sbomify.com/CVE-2016-6659/): Privilege escalation in Cloud Foundry v247 and earlier and UAA v3.9.2 & earlier and UAA bosh (uaa-release) v23 & earlier (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6637 and fix it if it is affected.

What it is: CVE-2016-6637 is a critical vulnerability in n/a, published on 30 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-6637 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.7
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.7
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.3.0.5
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.3.0.5
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.4.0; fixed in 3.4.4
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.4.0; fixed in 3.4.4
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.5.0; fixed in 3.7.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.5.0; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6637/ (Markdown: https://insights.sbomify.com/CVE-2016-6637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6637
- OSV: https://osv.dev/vulnerability/CVE-2016-6637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6637/
Summaries are generated and may contain mistakes; the official description above is the record.
