# CVE-2016-6657: Open redirect in PCF Elastic Runtime 1.8.x versions prior to 1.8.12 and PCF Ops Manager 1.7.x versions prior to 1.7.18 and 1.8.x versions prior to 1.8.10

> An open redirect vulnerability in Pivotal Cloud Foundry Elastic Runtime allows attackers to redirect users to malicious sites, requiring an upgrade to mitigate.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-774p-wgxm-ff63

## What is CVE-2016-6657?

CVE-2016-6657 is a high-severity vulnerability in PCF Elastic Runtime 1.8.x versions prior to 1.8.12 and PCF Ops Manager 1.7.x versions prior to 1.7.18 and 1.8.x versions prior to 1.8.10, published on 16 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An open redirect vulnerability has been detected with some Pivotal Cloud Foundry Elastic Runtime components. Users of affected versions should apply the following mitigation: Upgrade PCF Elastic Runtime 1.8.x versions to 1.8.12 or later. Upgrade PCF Ops Manager 1.7.x versions to 1.7.18 or later and 1.8.x versions to 1.8.10 or later.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2016-6657?

It affects 2 products.


Products: Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Ops Manager.

## How do I fix CVE-2016-6657?

No fix has been published for CVE-2016-6657 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-6657 being exploited?

There is no known exploitation of CVE-2016-6657 in the wild and no public exploit code.

## Other vulnerabilities in PCF Elastic Runtime 1.8.x versions prior to 1.8.12 and PCF Ops Manager 1.7.x versions prior to 1.7.18 and 1.8.x versions prior to 1.8.10

- [CVE-2017-2773](https://insights.sbomify.com/CVE-2017-2773/): Auth bypass in PCF Elastic Runtime (critical 9.8)
- [CVE-2017-4955](https://insights.sbomify.com/CVE-2017-4955/): Information disclosure in PCF Elastic Runtime (critical 9.8)
- [CVE-2017-4959](https://insights.sbomify.com/CVE-2017-4959/): Auth bypass in PCF Elastic Runtime (high 8.8)
- [CVE-2016-0896](https://insights.sbomify.com/CVE-2016-0896/): Security feature bypass in n/a (high 7.3)
- [CVE-2016-0926](https://insights.sbomify.com/CVE-2016-0926/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6657 and fix it if it is affected.

What it is: CVE-2016-6657 is a high-severity vulnerability in PCF Elastic Runtime 1.8.x versions prior to 1.8.12 and PCF Ops Manager 1.7.x versions prior to 1.7.18 and 1.8.x versions prior to 1.8.10, published on 16 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-6657 in the wild and no public exploit code.

Affected product: PCF Elastic Runtime 1.8.x versions prior to 1.8.12 and PCF Ops Manager 1.7.x versions prior to 1.7.18 and 1.8.x versions prior to 1.8.10. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6657/ (Markdown: https://insights.sbomify.com/CVE-2016-6657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6657
- OSV: https://osv.dev/vulnerability/CVE-2016-6657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6657/
Summaries are generated and may contain mistakes; the official description above is the record.
