# CVE-2016-6798: XML External Entity Reference in Apache Sling

> An attacker can exploit insecure XML parsing in Apache Sling to read sensitive files, perform SSRF, or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7g54-vgp6-jj5w

## What is CVE-2016-6798?

CVE-2016-6798 is a critical vulnerability in Apache Sling, published on 19 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the XSS Protection API module before 1.0.12 in Apache Sling, the method XSS.getValidXML() uses an insecure SAX parser to validate the input string, which allows for XXE attacks in all scripts which use this method to validate user input, potentially allowing an attacker to read sensitive data on the filesystem, perform same-site-request-forgery (SSRF), port-scanning behind the firewall or DoS the application.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2016-6798?

4 open source packages ship an affected version, including org.apache.sling:org.apache.sling.xss and org.apache.sling:org.apache.sling.xss.compat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.xss` | Maven | All versions | 1.0.12 |
| `org.apache.sling:org.apache.sling.xss` | Maven | All versions | 1.0.12 |
| `org.apache.sling:org.apache.sling.xss.compat` | Maven | All versions | 1.1.0 |
| `org.apache.sling:org.apache.sling.xss.compat` | Maven | All versions | 1.1.0 |

Products: Apache Sling.

## How do I fix CVE-2016-6798?

Upgrade org.apache.sling:org.apache.sling.xss to 1.0.12 or later.

## Is CVE-2016-6798 being exploited?

There is no known exploitation of CVE-2016-6798 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tafamace/CVE-2016-6798 (github_poc): https://github.com/tafamace/CVE-2016-6798

## Other vulnerabilities in Apache Sling

- [CVE-2016-5394](https://insights.sbomify.com/CVE-2016-5394/): Cross site scripting in Apache Sling (medium 6.1)
- [CVE-2013-4390](https://insights.sbomify.com/CVE-2013-4390/): Apache Sling Auth Core bundle vulnerable to Open Redirection (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6798 and fix it if it is affected.

What it is: CVE-2016-6798 is a critical vulnerability in Apache Sling, published on 19 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6798 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.xss (Maven): affected all versions; fixed in 1.0.12
- org.apache.sling:org.apache.sling.xss (Maven): affected all versions; fixed in 1.0.12
- org.apache.sling:org.apache.sling.xss.compat (Maven): affected all versions; fixed in 1.1.0
- org.apache.sling:org.apache.sling.xss.compat (Maven): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6798/ (Markdown: https://insights.sbomify.com/CVE-2016-6798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6798
- OSV: https://osv.dev/vulnerability/CVE-2016-6798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6798/
Summaries are generated and may contain mistakes; the official description above is the record.
