# CVE-2016-6800: Cross-site scripting in Apache OFBiz

> Attackers can inject JavaScript into blog fields, executing code in other users' browsers, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 30 Aug 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5r8q-h585-cc8r

## What is CVE-2016-6800?

CVE-2016-6800 is a medium-severity cross-site scripting vulnerability in Apache Ofbiz, published on 30 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The default configuration of the Apache OFBiz framework offers a blog functionality. Different users are able to operate blogs which are related to specific parties. In the form field for the creation of new blog articles the user input of the summary field as well as the article field is not properly sanitized. It is possible to inject arbitrary JavaScript code in these form fields. This code gets executed from the browser of every user who is visiting this article. Mitigation: Upgrade to Apache OFBiz 16.11.01.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-6800?

It affects 1 product.


Products: Apache Ofbiz.

## How do I fix CVE-2016-6800?

No fix has been published for CVE-2016-6800 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-6800 being exploited?

There is no known exploitation of CVE-2016-6800 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ofbiz

- [CVE-2024-45195](https://insights.sbomify.com/CVE-2024-45195/): Apache OFBiz Forced Browsing (critical 9.8, exploited in the wild)
- [CVE-2024-32113](https://insights.sbomify.com/CVE-2024-32113/): Apache OFBiz Path Traversal (critical 9.1, exploited in the wild)
- [CVE-2024-38856](https://insights.sbomify.com/CVE-2024-38856/): Apache OFBiz Incorrect Authorization (high 8.1, exploited in the wild)
- [CVE-2013-2250](https://insights.sbomify.com/CVE-2013-2250/): Code injection in n/a (critical 10.0)
- [CVE-2012-3506](https://insights.sbomify.com/CVE-2012-3506/): Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors. (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6800 and fix it if it is affected.

What it is: CVE-2016-6800 is a medium-severity cross-site scripting vulnerability in Apache Ofbiz, published on 30 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-6800 in the wild and no public exploit code.

Affected product: Apache Ofbiz. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6800/ (Markdown: https://insights.sbomify.com/CVE-2016-6800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6800
- OSV: https://osv.dev/vulnerability/CVE-2016-6800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6800/
Summaries are generated and may contain mistakes; the official description above is the record.
