# CVE-2016-6801: Apache Jackrabbit Authentication Hijacking Vulnerability

> Remote attackers can hijack user authentication to create resources via crafted HTTP POST requests in Apache Jackrabbit WebDAV.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-6801, DLA-629-1, DSA-3679-1, GHSA-9fc7-rhq3-wm7x, UBUNTU-CVE-2016-6801

## What is CVE-2016-6801?

CVE-2016-6801 is a high-severity vulnerability in Debian Debian Linux, published on 21 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site request forgery (CSRF) vulnerability in the CSRF content-type check in Jackrabbit-Webdav in Apache Jackrabbit 2.4.x before 2.4.6, 2.6.x before 2.6.6, 2.8.x before 2.8.3, 2.10.x before 2.10.4, 2.12.x before 2.12.4, and 2.13.x before 2.13.3 allows remote attackers to hijack the authentication of unspecified victims for requests that create a resource via an HTTP POST request with a (1) missing or (2) crafted Content-Type header.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2016-6801?

12 open source packages ship an affected version, including org.apache.jackrabbit:jackrabbit-webdav. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.10.0 | 2.10.4 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.10.0 | 2.10.4 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.12.0 | 2.12.4 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.12.0 | 2.12.4 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.13.0 | 2.13.3 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.13.0 | 2.13.3 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.4.0 | 2.4.6 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.4.0 | 2.4.6 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.6.0 | 2.6.6 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.6.0 | 2.6.6 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.8.0 | 2.8.3 |
| `org.apache.jackrabbit:jackrabbit-webdav` | Maven | From 2.8.0 | 2.8.3 |

Products: Apache Jackrabbit, Debian Debian Linux.

## How do I fix CVE-2016-6801?

Upgrade org.apache.jackrabbit:jackrabbit-webdav to a fixed version for your release line: 2.10.4, 2.12.4, 2.13.3 or 2.4.6.

## Is CVE-2016-6801 being exploited?

There is no known exploitation of CVE-2016-6801 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2023-37895](https://insights.sbomify.com/CVE-2023-37895/): Apache Jackrabbit RMI access can lead to RCE (critical 9.8)
- [CVE-2026-92414](https://insights.sbomify.com/CVE-2026-92414/): Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens (critical 9.3)
- [CVE-2025-53689](https://insights.sbomify.com/CVE-2025-53689/): Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons (high 8.8)
- [CVE-2026-92415](https://insights.sbomify.com/CVE-2026-92415/): Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies (medium 6.9)
- [CVE-2025-58782](https://insights.sbomify.com/CVE-2025-58782/): Apache Jackrabbit Core, Apache Jackrabbit JCR Commons: JNDI injection risk with JndiRepositoryFactory (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6801 and fix it if it is affected.

What it is: CVE-2016-6801 is a high-severity vulnerability in Debian Debian Linux, published on 21 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-6801 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.10.0; fixed in 2.10.4
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.10.0; fixed in 2.10.4
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.12.0; fixed in 2.12.4
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.12.0; fixed in 2.12.4
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.13.0; fixed in 2.13.3
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.13.0; fixed in 2.13.3
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.4.0; fixed in 2.4.6
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.4.0; fixed in 2.4.6
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.6.0; fixed in 2.6.6
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.6.0; fixed in 2.6.6
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.8.0; fixed in 2.8.3
- org.apache.jackrabbit:jackrabbit-webdav (Maven): affected from 2.8.0; fixed in 2.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6801/ (Markdown: https://insights.sbomify.com/CVE-2016-6801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6801
- OSV: https://osv.dev/vulnerability/CVE-2016-6801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6801/
Summaries are generated and may contain mistakes; the official description above is the record.
