# CVE-2016-6806: Apache Wicket vulnerable to CSRF attacks

> Apache Wicket's CSRF protection failed to check Referer headers and some server-side targets, allowing attackers to bypass CSRF defenses.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Oct 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xc66-mg8r-q6r5

## What is CVE-2016-6806?

CVE-2016-6806 is a high-severity vulnerability in Apache Wicket, published on 2 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Wicket 6.x before 6.25.0, 7.x before 7.5.0, and 8.0.0-M1 provide a CSRF prevention measure that fails to discover some cross origin requests. The mitigation is to not only check the Origin HTTP header, but also take the Referer HTTP header into account when no Origin was provided. Furthermore, not all Wicket server side targets were subjected to the CSRF check. This was also fixed.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2016-6806?

6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.wicket:wicket-core` | Maven | From 6.20.0 | 6.25.0 |
| `org.apache.wicket:wicket-core` | Maven | From 6.20.0 | 6.25.0 |
| `org.apache.wicket:wicket-core` | Maven | From 7.0.0 | 7.5.0 |
| `org.apache.wicket:wicket-core` | Maven | From 7.0.0 | 7.5.0 |
| `org.apache.wicket:wicket-core` | Maven | From 8.0.0-M1 | 8.0.0-M2 |
| `org.apache.wicket:wicket-core` | Maven | From 8.0.0-M1 | 8.0.0-M2 |

Products: Apache Wicket.

## How do I fix CVE-2016-6806?

Upgrade org.apache.wicket:wicket-core to a fixed version for your release line: 6.25.0, 7.5.0 or 8.0.0-M2.

## Is CVE-2016-6806 being exploited?

There is no known exploitation of CVE-2016-6806 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)
- [CVE-2026-43646](https://insights.sbomify.com/CVE-2026-43646/): Apache Wicket: crafted URLs can bypass PackageResourceGuard (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6806 and fix it if it is affected.

What it is: CVE-2016-6806 is a high-severity vulnerability in Apache Wicket, published on 2 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-6806 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.wicket:wicket-core (Maven): affected from 6.20.0; fixed in 6.25.0
- org.apache.wicket:wicket-core (Maven): affected from 6.20.0; fixed in 6.25.0
- org.apache.wicket:wicket-core (Maven): affected from 7.0.0; fixed in 7.5.0
- org.apache.wicket:wicket-core (Maven): affected from 7.0.0; fixed in 7.5.0
- org.apache.wicket:wicket-core (Maven): affected from 8.0.0-M1; fixed in 8.0.0-M2
- org.apache.wicket:wicket-core (Maven): affected from 8.0.0-M1; fixed in 8.0.0-M2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6806/ (Markdown: https://insights.sbomify.com/CVE-2016-6806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6806
- OSV: https://osv.dev/vulnerability/CVE-2016-6806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6806/
Summaries are generated and may contain mistakes; the official description above is the record.
