{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ambari:ambari. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-6807 in the wild and no public exploit code.","fix":"Upgrade org.apache.ambari:ambari to 2.4.2 or later.","what":"CVE-2016-6807 is a critical missing authorization vulnerability in Apache Ambari, published on 28 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-6807 and fix it if it is affected.\n\nWhat it is: CVE-2016-6807 is a critical missing authorization vulnerability in Apache Ambari, published on 28 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-6807 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ambari:ambari (Maven): affected from 2.4.0; fixed in 2.4.2\n- org.apache.ambari:ambari (Maven): affected from 2.4.0; fixed in 2.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6807/ (Markdown: https://insights.sbomify.com/CVE-2016-6807/index.md)","id":"CVE-2016-6807","markdown":"https://insights.sbomify.com/CVE-2016-6807/index.md","name":"CVE-2016-6807","record":{"aliases":["GHSA-j76q-99x2-v7vq"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Ambari","requires_auth":"none","summary":"Attackers can execute custom commands on Ambari Agent hosts without authorization, leading to unauthorized system access and potential privilege escalation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ambari","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Custom commands may be executed on Ambari Agent (2.4.x, before 2.4.2) hosts without authorization, leading to unauthorized access to operations that may affect the underlying system. Such operations are invoked by the Ambari Agent process on Ambari Agent hosts, as the user executing the Ambari Agent process.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Ambari Improper Access Control","id":"CVE-2016-6807","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2016-6808"},"packages":[{"ecosystem":"Maven","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"org.apache.ambari:ambari","purl":null,"source":"GHSA-j76q-99x2-v7vq"},{"ecosystem":"Maven","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"org.apache.ambari:ambari","purl":"pkg:maven/org.apache.ambari/ambari","source":"GHSA-j76q-99x2-v7vq"}],"prev":{"headline":"Apache Wicket vulnerable to CSRF attacks","id":"CVE-2016-6806"},"products":["Apache Ambari"],"published":"2017-03-28","related":[{"cvss_score":9.8,"headline":"Misconfiguration in Apache Ambari","id":"CVE-2017-5642","kev_date_added":null,"published":"2017-04-03"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2014-3582","kev_date_added":null,"published":"2017-03-29"},{"cvss_score":8.8,"headline":"Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts","id":"CVE-2024-51941","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.8,"headline":"Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition","id":"CVE-2025-23196","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.8,"headline":"Apache Ambari: authenticated users could perform command injection to perform RCE","id":"CVE-2023-50379","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":8.1,"headline":"Information disclosure in Apache Ambari","id":"CVE-2018-8042","kev_date_added":null,"published":"2018-07-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute custom commands on Ambari Agent hosts without authorization, leading to unauthorized system access and potential privilege escalation.","url":"https://insights.sbomify.com/CVE-2016-6807/"}