# CVE-2016-6807: Apache Ambari Improper Access Control

> Attackers can execute custom commands on Ambari Agent hosts without authorization, leading to unauthorized system access and potential privilege escalation.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j76q-99x2-v7vq

## What is CVE-2016-6807?

CVE-2016-6807 is a critical missing authorization vulnerability in Apache Ambari, published on 28 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Custom commands may be executed on Ambari Agent (2.4.x, before 2.4.2) hosts without authorization, leading to unauthorized access to operations that may affect the underlying system. Such operations are invoked by the Ambari Agent process on Ambari Agent hosts, as the user executing the Ambari Agent process.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-6807?

2 open source packages ship an affected version, including org.apache.ambari:ambari. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ambari:ambari` | Maven | From 2.4.0 | 2.4.2 |
| `org.apache.ambari:ambari` | Maven | From 2.4.0 | 2.4.2 |

Products: Apache Ambari.

## How do I fix CVE-2016-6807?

Upgrade org.apache.ambari:ambari to 2.4.2 or later.

## Is CVE-2016-6807 being exploited?

There is no known exploitation of CVE-2016-6807 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ambari

- [CVE-2017-5642](https://insights.sbomify.com/CVE-2017-5642/): Misconfiguration in Apache Ambari (critical 9.8)
- [CVE-2014-3582](https://insights.sbomify.com/CVE-2014-3582/): Command injection in n/a (critical 9.8)
- [CVE-2024-51941](https://insights.sbomify.com/CVE-2024-51941/): Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts (high 8.8)
- [CVE-2025-23196](https://insights.sbomify.com/CVE-2025-23196/): Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition (high 8.8)
- [CVE-2023-50379](https://insights.sbomify.com/CVE-2023-50379/): Apache Ambari: authenticated users could perform command injection to perform RCE (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6807 and fix it if it is affected.

What it is: CVE-2016-6807 is a critical missing authorization vulnerability in Apache Ambari, published on 28 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6807 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ambari:ambari (Maven): affected from 2.4.0; fixed in 2.4.2
- org.apache.ambari:ambari (Maven): affected from 2.4.0; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6807/ (Markdown: https://insights.sbomify.com/CVE-2016-6807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6807
- OSV: https://osv.dev/vulnerability/CVE-2016-6807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6807/
Summaries are generated and may contain mistakes; the official description above is the record.
