# CVE-2016-6809: Apache Tika allows Java code execution for serialized objects embedded in MATLAB files


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Apr 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-6809, GHSA-j8g6-2wh7-6439

## What is CVE-2016-6809?

CVE-2016-6809 is a critical vulnerability in n/a, published on 6 Apr 2017. 

### Official description

Apache Tika before 1.14 allows Java code execution for serialized objects embedded in MATLAB files. The issue exists because Tika invokes JMatIO to do native deserialization.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2016-6809?

2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika-core` | Maven | All versions | 1.14 |
| `org.apache.tika:tika-core` | Maven | All versions | 1.14 |

Products: Apache Nutch, Apache Tika.

## How do I fix CVE-2016-6809?

Upgrade org.apache.tika:tika-core to 1.14 or later.

## Is CVE-2016-6809 being exploited?

There is no known exploitation of CVE-2016-6809 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-41871](https://insights.sbomify.com/CVE-2026-41871/): Apache Nutch: Unauthenticated reflection-based job execution in Nutch Server (Nutch REST API) (critical 9.8)
- [CVE-2026-41869](https://insights.sbomify.com/CVE-2026-41869/): Apache Nutch: Unauthenticated forced shutdown and job interruption in Nutch Server (Nutch REST API) (critical 9.1)
- [CVE-2021-23901](https://insights.sbomify.com/CVE-2021-23901/): An XML external entity (XXE) injection vulnerability exists in the Nutch DmozParser (critical 9.1)
- [CVE-2026-41870](https://insights.sbomify.com/CVE-2026-41870/): Apache Nutch: Unauthenticated remote code execution (RCE) via JEXL injection in Nutch Server (Nutch REST API) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6809 and fix it if it is affected.

What it is: CVE-2016-6809 is a critical vulnerability in n/a, published on 6 Apr 2017. 
Exploitation: There is no known exploitation of CVE-2016-6809 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tika:tika-core (Maven): affected all versions; fixed in 1.14
- org.apache.tika:tika-core (Maven): affected all versions; fixed in 1.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6809/ (Markdown: https://insights.sbomify.com/CVE-2016-6809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6809
- OSV: https://osv.dev/vulnerability/CVE-2016-6809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6809/
Summaries are generated and may contain mistakes; the official description above is the record.
