{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-6810 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:activemq-client to 5.14.2 or later.","what":"CVE-2016-6810 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 10 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-6810 and fix it if it is affected.\n\nWhat it is: CVE-2016-6810 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 10 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-6810 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.14.2\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.14.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6810/ (Markdown: https://insights.sbomify.com/CVE-2016-6810/index.md)","id":"CVE-2016-6810","markdown":"https://insights.sbomify.com/CVE-2016-6810/index.md","name":"CVE-2016-6810","record":{"aliases":["DEBIAN-CVE-2016-6810","GHSA-5jg4-p78r-p5j3","UBUNTU-CVE-2016-6810"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"none","summary":"Cross-site scripting in the web administration console allows attackers to inject malicious scripts, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"activemq","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation Apache ActiveMQ","id":"CVE-2016-6810","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq"],"type":"xss","year":"2016"},"n_packages":2,"n_references":5,"next":{"headline":"Insecure Inherited Permissions in Apache Hadoop","id":"CVE-2016-6811"},"packages":[{"ecosystem":"Maven","fixed":["5.14.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-5jg4-p78r-p5j3"},{"ecosystem":"Maven","fixed":["5.14.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-5jg4-p78r-p5j3"}],"prev":{"headline":"Apache Tika allows Java code execution for serialized objects embedded in MATLAB files","id":"CVE-2016-6809"},"products":["Apache ActiveMQ"],"published":"2018-01-10","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Cross-site scripting in the web administration console allows attackers to inject malicious scripts, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2016-6810/"}