# CVE-2016-6811: Insecure Inherited Permissions in Apache Hadoop

> A user with yarn privileges can escalate to root and execute arbitrary commands in Apache Hadoop YARN.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-mf7c-35mq-75pj

## What is CVE-2016-6811?

CVE-2016-6811 is a high-severity vulnerability in n/a, published on 11 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Hadoop 2.x before 2.7.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Weakness: CWE-264

## Which versions are affected by CVE-2016-6811?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.0.0-alpha | 2.7.4 |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.0.0-alpha | 2.7.4 |

Products: Apache Hadoop.

## How do I fix CVE-2016-6811?

Upgrade org.apache.hadoop:hadoop-common to 2.7.4 or later.

## Is CVE-2016-6811 being exploited?

There is no known exploitation of CVE-2016-6811 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6811 and fix it if it is affected.

What it is: CVE-2016-6811 is a high-severity vulnerability in n/a, published on 11 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6811 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-common (Maven): affected from 2.0.0-alpha; fixed in 2.7.4
- org.apache.hadoop:hadoop-common (Maven): affected from 2.0.0-alpha; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6811/ (Markdown: https://insights.sbomify.com/CVE-2016-6811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6811
- OSV: https://osv.dev/vulnerability/CVE-2016-6811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6811/
Summaries are generated and may contain mistakes; the official description above is the record.
