# CVE-2016-6812: Improper Neutralization of Input During Web Page Generation in Apache CXF

> An attacker can inject matrix parameters into the request URL to trigger Cross-Site Scripting in the Apache CXF HTTP transport module's service list page.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Aug 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-vw2c-5wph-v92r

## What is CVE-2016-6812?

CVE-2016-6812 is a medium-severity cross-site scripting vulnerability in Apache Cxf, published on 10 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The HTTP transport module in Apache CXF prior to 3.0.12 and 3.1.x prior to 3.1.9 uses FormattedServiceListWriter to provide an HTML page which lists the names and absolute URL addresses of the available service endpoints. The module calculates the base URL using the current HttpServletRequest. The calculated base URL is used by FormattedServiceListWriter to build the service endpoint absolute URLs. If the unexpected matrix parameters have been injected into the request URL then these matrix parameters will find their way back to the client in the services list page which represents an XSS risk to the client.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-6812?

4 open source packages ship an affected version, including org.apache.cxf:cxf-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf:cxf-core` | Maven | All versions | 3.0.12 |
| `org.apache.cxf:cxf-core` | Maven | All versions | 3.0.12 |
| `org.apache.cxf:cxf-core` | Maven | From 3.1.0 | 3.1.9 |
| `org.apache.cxf:cxf-core` | Maven | From 3.1.0 | 3.1.9 |

Products: Apache Cxf.

## How do I fix CVE-2016-6812?

Upgrade org.apache.cxf:cxf-core to a fixed version for your release line: 3.0.12 or 3.1.9.

## Is CVE-2016-6812 being exploited?

There is no known exploitation of CVE-2016-6812 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/asf__cxf_CVE-2016-6812_3-0-11 (github_poc): https://github.com/shoucheng3/asf__cxf_CVE-2016-6812_3-0-11

## Other vulnerabilities in Apache Cxf

- [CVE-2012-2379](https://insights.sbomify.com/CVE-2012-2379/): XML Signature/Encryption Not Validated in Apache CXF (critical 10.0)
- [CVE-2026-66909](https://insights.sbomify.com/CVE-2026-66909/): Apache CXF: Unsafe deserialization of inbound JMS ObjectMessage (critical 9.8)
- [CVE-2026-68079](https://insights.sbomify.com/CVE-2026-68079/): Apache CXF: DefaultEncryptingCodeDataProvider allows unlimited authorization code replay (critical 9.8)
- [CVE-2026-50628](https://insights.sbomify.com/CVE-2026-50628/): Apache CXF: OAuth2: Inverted IP Binding Check Defeats Security Control (critical 9.8)
- [CVE-2025-48913](https://insights.sbomify.com/CVE-2025-48913/): Apache CXF: Untrusted JMS configuration can lead to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6812 and fix it if it is affected.

What it is: CVE-2016-6812 is a medium-severity cross-site scripting vulnerability in Apache Cxf, published on 10 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-6812 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf:cxf-core (Maven): affected all versions; fixed in 3.0.12
- org.apache.cxf:cxf-core (Maven): affected all versions; fixed in 3.0.12
- org.apache.cxf:cxf-core (Maven): affected from 3.1.0; fixed in 3.1.9
- org.apache.cxf:cxf-core (Maven): affected from 3.1.0; fixed in 3.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6812/ (Markdown: https://insights.sbomify.com/CVE-2016-6812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6812
- OSV: https://osv.dev/vulnerability/CVE-2016-6812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6812/
Summaries are generated and may contain mistakes; the official description above is the record.
