{"answers":{"affected":"4 open source packages ship an affected version, including org.codehaus.groovy:groovy and org.codehaus.groovy:groovy-all. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-6814 in the wild and no public exploit code.","fix":"Upgrade org.codehaus.groovy:groovy to 2.4.8 or later.","what":"CVE-2016-6814 is a critical unsafe deserialization vulnerability in Redhat Enterprise Linux Server, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-6814 and fix it if it is affected.\n\nWhat it is: CVE-2016-6814 is a critical unsafe deserialization vulnerability in Redhat Enterprise Linux Server, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-6814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.codehaus.groovy:groovy (Maven): affected from 1.7.0; fixed in 2.4.8\n- org.codehaus.groovy:groovy (Maven): affected from 1.7.0; fixed in 2.4.8\n- org.codehaus.groovy:groovy-all (Maven): affected from 1.7.0; fixed in 2.4.8\n- org.codehaus.groovy:groovy-all (Maven): affected from 1.7.0; fixed in 2.4.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6814/ (Markdown: https://insights.sbomify.com/CVE-2016-6814/index.md)","id":"CVE-2016-6814","markdown":"https://insights.sbomify.com/CVE-2016-6814/index.md","name":"CVE-2016-6814","record":{"aliases":["DEBIAN-CVE-2016-6814","DLA-794-1","GHSA-xphj-m9cc-8fmq","MGASA-2017-0311","UBUNTU-CVE-2016-6814","USN-4795-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Groovy library","requires_auth":"none","summary":"Attackers can execute arbitrary code by sending specially crafted serialized objects to applications using vulnerable Groovy versions.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"groovy","vendor":"apache"},{"product":"enterprise_linux_server","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"When an application with unsupported Codehaus versions of Groovy from 1.7.0 to 2.4.3, Apache Groovy 2.4.4 to 2.4.7 on classpath uses standard Java serialization mechanisms, e.g. to communicate between servers or to store local data, it was possible for an attacker to bake a special serialized object that will execute code directly when deserialized. All applications which rely on serialization and do not isolate the code which deserializes objects were subject to this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of Untrusted Data in Groovy","id":"CVE-2016-6814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"redhat:enterprise_linux_server","products":["redhat:enterprise_linux_server"],"type":"deserialization","year":"2016"},"n_packages":4,"n_references":16,"next":{"headline":"Moderate severity vulnerability that affects org.apache.ranger:ranger","id":"CVE-2016-6815"},"packages":[{"ecosystem":"Maven","fixed":["2.4.8"],"introduced":["1.7.0"],"last_affected":[],"package":"org.codehaus.groovy:groovy","purl":null,"source":"GHSA-xphj-m9cc-8fmq"},{"ecosystem":"Maven","fixed":["2.4.8"],"introduced":["1.7.0"],"last_affected":[],"package":"org.codehaus.groovy:groovy","purl":"pkg:maven/org.codehaus.groovy/groovy","source":"GHSA-xphj-m9cc-8fmq"},{"ecosystem":"Maven","fixed":["2.4.8"],"introduced":["1.7.0"],"last_affected":[],"package":"org.codehaus.groovy:groovy-all","purl":null,"source":"GHSA-xphj-m9cc-8fmq"},{"ecosystem":"Maven","fixed":["2.4.8"],"introduced":["1.7.0"],"last_affected":[],"package":"org.codehaus.groovy:groovy-all","purl":"pkg:maven/org.codehaus.groovy/groovy-all","source":"GHSA-xphj-m9cc-8fmq"}],"prev":{"headline":"Missing authorization in Apache CloudStack","id":"CVE-2016-6813"},"products":["n/a"],"published":"2018-01-18","related":[{"cvss_score":9.8,"headline":"Improper Neutralization of Special Elements in Output Used by a Downstream Component in Apache Groovy","id":"CVE-2015-3253","kev_date_added":null,"published":"2015-08-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by sending specially crafted serialized objects to applications using vulnerable Groovy versions.","url":"https://insights.sbomify.com/CVE-2016-6814/"}