CVE-2016-6830 Memory corruption in n/a

Critical 9.8 Published Updated

Buffer overflow in CHICKEN Scheme process execution allows attackers to execute arbitrary code via crafted arguments or environment variables.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-6830?

CVE-2016-6830 is a critical memory corruption vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The "process-execute" and "process-spawn" procedures in CHICKEN Scheme used fixed-size buffers for holding the arguments and environment variables to use in its execve() call. This would allow user-supplied argument/environment variable lists to trigger a buffer overrun. This affects all releases of CHICKEN up to and including 4.11 (it will be fixed in 4.12 and 5.0, which are not yet released).

Weakness: CWE-119

Which versions are affected by CVE-2016-6830?

It affects 1 product.

Products include Call-Cc Chicken.

How do I fix CVE-2016-6830?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2016-6830 being exploited?

There is no known exploitation of CVE-2016-6830 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2023-NZ21733, DEBIAN-CVE-2016-6830, GHSA-x8qm-7p8g-qf87, UBUNTU-CVE-2016-6830.

Is CVE-2016-6830 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free