CVE-2016-6831 Denial of service in n/a

High 7.5 Published Updated

An attacker can cause resource exhaustion and denial of service by triggering memory leaks in process execution procedures.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-6831?

CVE-2016-6831 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The "process-execute" and "process-spawn" procedures did not free memory correctly when the execve() call failed, resulting in a memory leak. This could be abused by an attacker to cause resource exhaustion or a denial of service. This affects all releases of CHICKEN up to and including 4.11 (it will be fixed in 4.12 and 5.0, which are not yet released).

Weakness: CWE-400

Which versions are affected by CVE-2016-6831?

It affects 1 product.

Products include Call-Cc Chicken.

How do I fix CVE-2016-6831?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2016-6831 being exploited?

There is no known exploitation of CVE-2016-6831 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2023-EI38317, DEBIAN-CVE-2016-6831, GHSA-x279-7m5p-wjmv, UBUNTU-CVE-2016-6831.

Is CVE-2016-6831 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free