# CVE-2016-6831: Denial of service in n/a

> An attacker can cause resource exhaustion and denial of service by triggering memory leaks in process execution procedures.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** CLEANSTART-2023-EI38317, DEBIAN-CVE-2016-6831, GHSA-x279-7m5p-wjmv, UBUNTU-CVE-2016-6831

## What is CVE-2016-6831?

CVE-2016-6831 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The "process-execute" and "process-spawn" procedures did not free memory correctly when the execve() call failed, resulting in a memory leak. This could be abused by an attacker to cause resource exhaustion or a denial of service. This affects all releases of CHICKEN up to and including 4.11 (it will be fixed in 4.12 and 5.0, which are not yet released).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2016-6831?

It affects 1 product.


Products: Call-Cc Chicken.

## How do I fix CVE-2016-6831?

Upgrade to a fixed version.

## Is CVE-2016-6831 being exploited?

There is no known exploitation of CVE-2016-6831 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-45145](https://insights.sbomify.com/CVE-2022-45145/): Command injection in n/a (critical 9.8)
- [CVE-2014-6310](https://insights.sbomify.com/CVE-2014-6310/): Memory corruption in n/a (critical 9.8)
- [CVE-2012-6125](https://insights.sbomify.com/CVE-2012-6125/): Denial of service in chicken (critical 9.8)
- [CVE-2016-6830](https://insights.sbomify.com/CVE-2016-6830/): Memory corruption in n/a (critical 9.8)
- [CVE-2013-2024](https://insights.sbomify.com/CVE-2013-2024/): Command injection in chicken (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-6831 and fix it if it is affected.

What it is: CVE-2016-6831 is a high-severity denial of service vulnerability in n/a, published on 10 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-6831 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-6831/ (Markdown: https://insights.sbomify.com/CVE-2016-6831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-6831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-6831
- OSV: https://osv.dev/vulnerability/CVE-2016-6831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-6831/
Summaries are generated and may contain mistakes; the official description above is the record.
