{"answers":{"affected":"It affects 5 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-6855 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2016-6855 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 7 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-6855 and fix it if it is affected.\n\nWhat it is: CVE-2016-6855 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 7 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-6855 exists.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6855/ (Markdown: https://insights.sbomify.com/CVE-2016-6855/index.md)","id":"CVE-2016-6855","markdown":"https://insights.sbomify.com/CVE-2016-6855/index.md","name":"CVE-2016-6855","record":{"aliases":["DEBIAN-CVE-2016-6855","DLA-2185-1","DLA-605-1","GHSA-7jwp-58q4-9rxh","MGASA-2016-0297","SUSE-SU-2016:2827-1","UBUNTU-CVE-2016-6855","USN-3069-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Eye of GNOME image viewer","requires_auth":"none","summary":"Remote attackers can cause a denial of service via out-of-bounds write in Eye of GNOME when processing invalid UTF-8 data.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"fedora","vendor":"fedoraproject"},{"product":"eye_of_gnome","vendor":"gnome"},{"product":"leap","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Eye of GNOME (aka eog) 3.16.5, 3.17.x, 3.18.x before 3.18.3, 3.19.x, and 3.20.x before 3.20.4, when used with glib before 2.44.1, allow remote attackers to cause a denial of service (out-of-bounds write and crash) via vectors involving passing invalid UTF-8 to GMarkup.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP1","SUSE:Linux Enterprise Server 12 SP1","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:Linux Enterprise Software Development Kit 12 SP1"],"exploits":{"exploitdb":1,"first_seen":"2016-08-23","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2016-08-23","kind":"exploitdb","ref":"40291","stars":null,"title":"Eye of Gnome 3.10.2 - GMarkup Out of Bounds Write"}],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2016-6855","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","fedoraproject:fedora","opensuse:leap","opensuse:opensuse"],"type":"memory_corruption","year":"2016"},"n_packages":4,"n_references":13,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-6856"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP1","fixed":["3.10.2-2.3.1"],"introduced":["0"],"last_affected":[],"package":"eog","purl":"pkg:rpm/suse/eog\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP1","source":"SUSE-SU-2016:2827-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1","fixed":["3.10.2-2.3.1"],"introduced":["0"],"last_affected":[],"package":"eog","purl":"pkg:rpm/suse/eog\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1","source":"SUSE-SU-2016:2827-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["3.10.2-2.3.1"],"introduced":["0"],"last_affected":[],"package":"eog","purl":"pkg:rpm/suse/eog\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2016:2827-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP1","fixed":["3.10.2-2.3.1"],"introduced":["0"],"last_affected":[],"package":"eog","purl":"pkg:rpm/suse/eog\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP1","source":"SUSE-SU-2016:2827-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-6854"},"products":["n/a"],"published":"2016-09-07","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via out-of-bounds write in Eye of GNOME when processing invalid UTF-8 data.","url":"https://insights.sbomify.com/CVE-2016-6855/"}