{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-6893 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-6893 is a high-severity vulnerability in n/a, published on 2 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-6893 and fix it if it is affected.\n\nWhat it is: CVE-2016-6893 is a high-severity vulnerability in n/a, published on 2 Sep 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-6893 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-6893/ (Markdown: https://insights.sbomify.com/CVE-2016-6893/index.md)","id":"CVE-2016-6893","markdown":"https://insights.sbomify.com/CVE-2016-6893/index.md","name":"CVE-2016-6893","record":{"aliases":["DLA-608-1","DSA-3668-1","GHSA-46p3-9vjv-gq2w","MGASA-2016-0343","SUSE-SU-2018:1638-1","SUSE-SU-2019:14068-1","UBUNTU-CVE-2016-6893"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"GNU Mailman","requires_auth":"none","summary":"Remote attackers can hijack user authentication via CSRF to modify options and potentially access victim credentials in GNU Mailman.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mailman","vendor":"gnu"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-site request forgery (CSRF) vulnerability in the user options page in GNU Mailman 2.1.x before 2.1.23 allows remote attackers to hijack the authentication of arbitrary users for requests that modify an option, as demonstrated by gaining access to the credentials of a victim's account.","ecosystems":["SUSE:Linux Enterprise Point of Sale 11 SP3","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server 11 SP4-LTSS","SUSE:Linux Enterprise Server for SAP Applications 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-6893","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2016"},"n_packages":4,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-6894"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Point of Sale 11 SP3","fixed":["2.1.15-9.6.12.1"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:rpm/suse/mailman\u0026distro=SUSE%20Linux%20Enterprise%20Point%20of%20Sale%2011%20SP3","source":"SUSE-SU-2019:14068-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["2.1.15-9.6.3.1"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:rpm/suse/mailman\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2018:1638-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4-LTSS","fixed":["2.1.15-9.6.12.1"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:rpm/suse/mailman\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4-LTSS","source":"SUSE-SU-2019:14068-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["2.1.15-9.6.3.1"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:rpm/suse/mailman\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2018:1638-1"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2016-6892"},"products":["n/a"],"published":"2016-09-02","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-7123","kev_date_added":null,"published":"2016-09-02"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2005-4153","kev_date_added":null,"published":"2005-12-11"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2006-2191","kev_date_added":null,"published":"2006-09-19"},{"cvss_score":7.5,"headline":"Weak cryptography in n/a","id":"CVE-2004-1143","kev_date_added":null,"published":"2005-01-19"},{"cvss_score":7.5,"headline":"Cross-site scripting in n/a","id":"CVE-2002-0855","kev_date_added":null,"published":"2002-08-14"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2001-1132","kev_date_added":null,"published":"2002-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can hijack user authentication via CSRF to modify options and potentially access victim credentials in GNU Mailman.","url":"https://insights.sbomify.com/CVE-2016-6893/"}