CVE-2016-7038 Moodle Weak Password Recovery Mechanism for Forgotten Password
Attackers can retain access via old web service tokens after a user password change, bypassing security controls in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-7038?
CVE-2016-7038 is a high-severity vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Moodle 2.x and 3.x, web service tokens are not invalidated when the user password is changed or forced to be changed.
Weakness: CWE-640
Which versions are affected by CVE-2016-7038?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7 | 2.7.16 |
moodle/moodle Packagist | From 2.7 | 2.7.16 |
moodle/moodle Packagist | From 2.9 | 2.9.8 |
moodle/moodle Packagist | From 2.9 | 2.9.8 |
moodle/moodle Packagist | From 3.0 | 3.0.6 |
moodle/moodle Packagist | From 3.0 | 3.0.6 |
2 more packages
moodle/moodle Packagist | From 3.1 | 3.1.2 |
moodle/moodle Packagist | From 3.1 | 3.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2016-7038?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.16, 2.9.8, 3.0.6 or 3.1.2.
Is CVE-2016-7038 being exploited?
There is no known exploitation of CVE-2016-7038 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-2phx-w35g-x9vm, UBUNTU-CVE-2016-7038.